Installer le Kernel 3.2 sur Ubuntu 11.10


Vous souhaitez mettre à jour le kernel en version 3.2 sur votre Ubuntu 11.10. Sachez que cela est risqué pour qui ne connaît pas comment fonctionne grub ! Mais pour les plus téméraire voici le tuto.

kernel 3 655x350 560x299 Installer le Kernel 3.2 sur Ubuntu 11.10

Comme pour toute mise à jour du kernel on retrouve de nombreuses corrections de bugs et améliorations dont vous pouvez trouver le détail sur LinuxFr. Phoronix nous gratifie d’un benchmark des différents noyaux ou on peut remarquer de performances en progression surtout au niveau des filesystems EXT4 et BTRFS, et des drivers de cartes graphiques.

Installer le noyau Linux 3.2 dans Ubuntu 11.10

Pour commencer ouverz un fenêtre Terminal :

sudo add-apt-repository ppa:francisbrwn9/kernels
sudo apt-get update
sudo apt-get dist-upgrade

Redémarrez votre ordinateur. Pour contrôler ouvrez une fenêtre Terminal et exécutez la commande suivante :

uname-r

Amusez-vous!


Vous pourriez lire aussi :

  1. Ubuntu 11.04 – Installation du kernel 2.6.39 pour corriger un bug entre Unity et OpenGL
  2. Ubuntu 11.04 – Installer le kernel 3.0
  3. Ubuntu Tweak 0.5.2
  4. Ubuntu : Installer le dernier kernel 2.6.30
  5. Installer le dernier kernel (2.6.29, …) sur Ubuntu Intrepid


  • roger64

    Bonjour
    Merci pour vos très intéressantes infos.

    Propriétaire d’un laptop Toshiba récent, je ne peux profiter des réglages FN que si l’option Toshiba est activée dans le noyau, ce qui ne peut se faire normalement qu’en compilant. Techniquement, je ne sais pas faire. C’est pourquoi, je souhaiterais demander à l’auteur du PPA s’il pouvait intégrer cette -petite -spécification.

    Avez-vous son mail?

  • http://www.actualia.fr sebas66

    bonjour,

    chez moi sur mes deux pc cela ne marche pas il me dit not found dés la première commande :

    sudo: apt-add-garde: command not found

    cordialement

    seb

    • Stephane

      Corrigé. Désolé

  • Franck

    Bonjour,
    Merci pour le tuto :) excellent et fonctionnel sur Mint 12.
    Néanmoins, après une installation *fresh* du système, pour que le kernel soit vraiment opérationnel et optimisé, il a fallu que j’installe les drivers nvidia proprio; avant celà, des lags, ralentissements, et souvent écran figé.
    Mais au final, que du bon :) , nette amélioration des perfs comparé au kernel de base 3.0.14

  • Chr0nic

    Installation nikel.

    Mais toujours pas une meilleure autonomie pour les lapstops !! :(

  • Raptor039

    Bonjour à vous !

    Tout d’abord félicitation à vous pour votre blog, je dois dire que je le suis avec intention et je ne suis jamais déçu des nouveauté que vous rédigez.

    Je rencontre cependant un souci, je me débrouille à peu près sous linux mais je dois dire que la je bloque. En effet j’ai effectué la mise à jour du kernel linux en suivant votre tutoriel, et ma version est la suivant : 3.2.1-030201-generic-pae

    Je ne sais pas ce que peut signifier PAE, dans le grub j’en ai plusieurs mais celui-ci étant en premier sur la liste, je l’ai choisi comme Kernel par défaut. La n’est pas le souci, tout fonctionne à merveille. Le problème que je rencontre est dans l’utilisation de Virtualbox, en effet lorsque je tente de démarrer une machine virtuelle, le logiciel me renvois une erreur qui est la suivante : [img]http://img687.imageshack.us/img687/8613/capturedu20120118210245.png[/img]

    Si jamais vous avez une idée de comment régler ce souci plutôt embêtant pour quelqu’un comme moi qui utilise régulièrement Virtualbox.

    Merci d’avance pour votre future réponse. Et longue vie à votre site !

    Amicalement, Raptor.

    • Stephane

      Le kernel pae est un kernel 32 bits qui permet d’adresser plus de 3Go. Pour le pb su r virtualbox je rendrai plus tard….

      Les commentaires sont modérés avant d’être affiché.

    • Stephane

      Il faut réinstaller virtualbox suite au changement de kernel

  • Raptor039

    Merci beaucoup pour votre réponse Stéphane.

    Je viens de suivre votre conseil et d’installer la dernière version de Virtualbox (4.1.8) disponible depuis le Site d’Oracle.

    Voila l’erreur que j’obtiens lorsque je tente d’installer le paquet : http://img716.imageshack.us/img716/1645/capturedu20120118222450.png

    Peut être que la dernière version en date de Virtualbox ne prend pas encore en charge le kernel ? Je dois dire que je suis un peu perdu…

    Merci d’avance pour votre réponse !

    Amicalement, Raptor.